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0.1. Measurement procedure

The idea of the experiment is to sweep the frequency at a fixed external field. This is done for a range of
applied fields H⃗ ranging from 2200 Oe to −2200 Oe. From the experimental data the uniaxial anisotropy
field HK , the saturation magnetization MS and the Gilbert damping parameter α can be obtained by fit-
ting the data.

Activity 1 - Set the VNA parameters - For VNA model E8363C (if you are using VNA
model 5071B go to appendix A and read it before continuing).

Although the measurement settings of the VNA are controlled by a LabVIEW program sometimes
there still occur inconveniences. Therefore it is highly recommended to set the VNA directly by hand

and select the same settings for the LabVIEW program afterwards.

ATTENTION!
Don’t touch the experiment during the measurement and while setting the VNA!

Figure 1: Control panel of the VNA.
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• Power on the VNA.

• Choose the S21 scattering matrix parameter:

◦ press Meas → select S21

• Open a 2nd window (finally one window for the magnitude and for the phase of S21 is needed):

◦ right mouse click → choose New window....

◦ right mouse click → choose New trace.... → choose S21

• Choose the units of the y-axis:

◦ mark upper window (with mouse) → press Format → choose Log Mag 1

◦ mark lower window (with mouse) → press Format → choose Phase

• Set the frequency range:

◦ press Freq → Start insert 10 MHz with the numeric pad

◦ press Freq → Stop insert 12 GHz with the numeric pad

• Autoscale the spectrum:

◦ mark upper window (with mouse) → press Scale → choose Autoscale All

◦ mark lower window (with mouse) → press Scale → choose Autoscale All

• Set the number of measuring points in the plot (resolution):

◦ press Sweep → Number of points insert 2000 with the numeric pad

→ confirm with Enter (numeric pad)

• Set the IF bandwidth2 and the averaging:

◦ press Avg → press IF bandwidth → insert 0.5 kHz or 1 kHz 3

◦ press Avg → press Averaging on|OFF till “OFF” is written in capital letters4

Activity 1.1 (optional) - Save the settings
You can save the settings of the VNA for recalling them at a later time. This is advisable if you
measure several days.

• Save the settings:

◦ press Save → Save As... Edit Filename (bottom left of screen) → keyboard pops up →
insert a name, e.g. “settings_juan” → confirm with OK

1The Lin Mag case would represent V R
2 /V S

1 , whereas the Log Mag case gives 20log
(
V R

2 /V S
1
)
= 10log

(
PR

2 /PS
1
)

keeping in
mind that P =V I =V 2/R.
The Log Mag value is given in dB which is a logarithmic unit for the base 10 logarithm and defined as P(dB) = 10 ·
log

(
Px/Py

)
= 20 · log

(
Vx/Vy

)
. For example a power ratio of PR

2 /PS
1 = 1 corresponds to 0 dB and PR

2 /PS
1 = 10 corresponds

to 10 dB et cetera.
2Some device (synthesizer) inside the VNA generates such a high frequency signal that the VNA cannot detect it. These high

radio frequencies are multiplied by a low frequency from a local oscillator. From this frequency mixing a new intermediate
frequency (IF) arises. This process is done a few times to convert the radio frequency to a manageable one. The IF
bandwidth is connected to the accuracy with which this mixing process is done. A higher accuracy needs more processing
time than a lower one.

3For higher values for the IF bandwidth the measurement is faster but the result less exact.
4In general, taking more averages improves the result. However, for this student lab the accuracy without additional averaging

is sufficient.
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• Recall the settings:

◦ press Recall → choose your file, e.g “2rows.csa” o ”settings_juan.csa” (press More to
see all files)

All LabVIEW programs for initiating and evaluating the measurement are found in the
folder Students_FMR_programs on the desktop.

• create a new folder with the direction C:\FMR\# (# is a number)

• open LabVIEW → open
S parameters loops in field_PNA_L 50GHz_s12-solenoid6_2VNAS.vi (alternatively this

program can be found in the folder Students_FMR_programs on the desktop)

◦ insert start frequency (Hz) → 10 MHz

◦ insert stop frequency (Hz) → 12 GHz

◦ choose Power dBM → insert 00 in the green field5

◦ choose Save file in → C:FMR#

◦ choose points in trace → insert 2000 6

◦ choose IF Bandwidth (Hz) → insert 0.5 kHz or 1 kHz , respectively

◦ choose averages on/off → off

◦ insert seconds to wait in case of off averaging → 6 (time between the measurements)

◦ choose RF (ON/OFF) → ON

◦ choose Horizontal Scale → LIN

◦ choose Solenoid: → 6 7

• turn on the power supply8

◦ press MODE VOLT/CURR to change to current source

◦ press STANDBY to leave the standby mode

5In general you could create an array for measuring with different powers. We don’t need this for this experiment. 0 dBM
corresponding to 1 mV is fine for this lab. The blue box left to the green box indicates the chosen array element and should
be 0 .

6This gives the precision of the measurement. 3201 is the maximal resolution.
7This parameter refers to the conversion of current into field. The conversion might differ for different CPWs. The solenoid

with number 6 is used for this lab course.
8The power supply is controlled by the LabVIEW program but in general, it can also be regulated by hand.
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Activity 3 - Check the field plan
Once started the measurement, the first thing the LabVIEW program will do is to check the field plan.
The field plan gives a list of the measurement fields for which a measurement will be taken (first
column). The second column indicates if zero or one measurement shall be taken.
Checking the field plan:

• go to C:\temp → open Plan H.dat

• recommended range of field plan from 2200 Oe to −2200 Oe in steps of 4 Oe, finish with a line
with 0 Oe and 0 measurements

◦ If the field plan does not already contain the recommended values you can replace it by a
new one using the LabVIEW program make field plan.vi which an be found in the folder

Students_FMR_programs on the desktop.

Activity 4 - Normalize the spectrum
The spectrum needs to be normalized in order to reduce the background signal. This means a reference
spectrum is taken at a certain external field H⃗ and is subtracted form all measurement spectra. Instead
of a single negative peak this spectra contains although a fake peak, namely the inverse negative peak
of the reference spectrum.
When measuring in a range from −2200 Oe to 2200 Oe, we can normalize at the highest field of
2200 Oe. For the chosen frequency range from 10 MHz to 12 GHz the relict of the normalization is then
pushed outside the spectrum under consideration.
We recommend to normalize while setting the current with the LabVIEW program.
Pause the LabVIEW program S parameters loops in field_PNA_L 50GHz_s12-solenoid6_2VNAS.vi
for proceeding with the normalization:

• Start the measurement → press the white arrow on the top left of the LabVIEW program.

• Immediately press the pause sign next to the arrow. It will pause as soon as the highest field is
reached (in our case 2200 Oe).

• Normalize the spectrum with the VNA:

◦ press macro local (This enables you to use the buttons when the system is PC controlled.)

◦ mark upper window (with mouse) → press Memory → choose Normalize

◦ mark lower window (with mouse) → press Memory → choose Normalize

◦ Don’t touch the experimental set-up while normalizing!

• Continue the measurement with pressing the pause bottom again.

Alternatively the normalization can be done by hand (not advised because the setting should be touched
the least possible).

• Set the current at the power supply by hand:

◦ set 1.3 A 9 by hand

• Normalize the spectrum with the VNA:

◦ press Memory → choose Normalize

Note: For a wider range of frequency values the normalization peak would appear in the spectrum
under consideration. In this case it is advisable to normalize at zero field (corresponding to 0 A).

9This corresponds to an applied field of about 1877.2338 Oe.
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Activity 5 - Run the measurement
After normalizing the measurement and repressing pause , running the experiment will take about 6
hours. The program finishes automatically.
During the measurement the LabVIEW creates a file for each field. They contain three columns, giving
the frequency, as well as the amplitude and the phase of the S21 parameter. The file name is related to
the field, e.g. V=002dBm_H=2.16026E+3G_T=300.0E+0K.DAT.

1. Data analysis & Evaluation

1.1. Evaluation of the measurement data

As already mentioned the aim of the experiment is to determine the anisotropy field HK , the saturation
magnetization MS and the Gilbert damping parameter α . There exist different ways to process the data
in order to obtain the above specified parameters. We will present some of them.
For the evaluation only one branch of the symmetric curve is needed. In the following neglect one
branch or take the mean value of the positive and negative branch to ameliorate your measurement
results.

Prepare the data
Start processing you data with the LabVIEW program measurement_processing.vi .

• choose Path → insert the path referring to the file with highest field, e.g.
V=002dBm_H=2.16026E+3G_T=300.0E+0K.DAT (The program normalizes again and
processes all files stored in the same folder.)

• choose T/H → insert H

Press the white arrow to run the program.
The program converts magnitude and phase of S21 into imaginary part and real part. It presents you a
3D plot of the real part of the S21 parameter and of its derivative with respect to the field. In general the
plot of the derivative reproduces a sharper plot. The program creates several new files stored in your
folder C:/FMR#:
ImFIT.dat, IMmu.dat, R(Re+IM).dat, Remu.dat, fields.dat, frequencies.dat, 2D_array.dat,
2D_array_derivative.dat
The most important ones for you in the following are:

• 2D_array.dat: gives an array with the real part of S21

• 2D_array_derivative.dat: gives an array with the derivative (with respect to the field) of the real
part of S21

Possibility A: Proceed data analysis with LabVIEW
For the first task you need to plot the resonance frequencies against the corresponding fields. If your
data quality is good10 you can use the LabVIEW program resonance_frequencies.vi to extract them.
Insert the path of your 2D_array.dat–file and run the LabVIEW program. The program finds the
minimum value of the frequency for each field and creates a new file resonance_freqs.dat containing
one column with the field and second with the corresponding resonance frequency. Delete bad data11

points in the following procedure if necessary.
You can use another LabVIEW program FWHM_students.vi for the second part. Insert the path to the
file 2D_array_derivative.dat and run the program. The output file FWHM.dat contains two columns,

10If the resonance frequency is only at a local minimum but not at a global minimum the program might not work properly.
11Bad data points are data points that clearly don’t belong to the curve you obtain.
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one for the value of FWHM in Oe and one for the corresponding frequencies. In the final fitting
procedure to obtain α it is very important to choose only the range with good data points.
The best way to determine the FWHM of a (negative) peak is to fit the curve – in our case Re(S21)
against H for fixed frequencies – with a Lorentz curve

L(x) = y0 +
2A
π

ω

4(x− x0)2 +ω2 . (1)

The fit parameter x0 gives the centre of the curve and ω the FWHM. The parameter for the area, A, is
one for a perfect Lorentz curve.
However, the LabVIEW program proceeds in a different way to obtain approximately the FWHM. It
calculates the difference between minimum x1 and maximum x2 of the differentiated S21-curve (this
means the distance between the points where the slope of the original plot is maximal). We can express
this distance in terms of the FWHM ω

△x = x2 − x1 =

√
(3)
3

ω ≈ 0.58ω. (2)

Therefore, the LabVIEW program multiplies this value at the end with the reciprocal of 0.58 to obtain a
good approximation for the FWHM.

Possibility B: Proceed data analysis with Origin
Instead of proceeding as described in previous section (Possibility A) the proceeding data analysis can
also be done by hand with a suitable program, e.g. OriginPro8 installed on the PC in the lab. (This is
for example necessary if the resonance frequency is no global minimum of you data).
Evaluate the first part with Origin

• Open a new matrix:

◦ File → New... → Matrix

• Import the 2D_array.dat–file:

◦ File → Import → Single ASCII → choose 2D_array.dat

• Plot the data in 3D:

◦ Plot → Image → Profiles

• Make the plot less blurred:

◦ right click on plot → Plot Details... → choose Layer1 → choose Size/Speed → untick

Matrix data, maximum points per dimension

Take care which axis denotes field and which frequency. Figure 2 gives an example of how the plot
might look like for a single branch. Changing the position of the yellow cursors changes the cross
section of Re(S21) against field (upper plot) or field against Re(S21) (right plot), respectively.

• Examine at least for 20 fixed fields the cross section Re(S21) against frequency:

◦ right click on plot → Go to Horizontal/Vertical =>then click 2 times in plot => plot
details=>worksheet>Save data for fits

◦ a new table pops up → make a new 2D plot

◦ fit the peak with a Lorentz curve to obtain the position of the plot12 or use the Data Reader
for determining f0 approximately

12For making a Lorentzian fit can be done with Origin via Fitting → Nonlinear Curve Fit → choose Open Dialog... →

choose Settings → Function Selection → Function → Lorentz . Make sure you restrict the active set of points to a
small surrounding around the peak.
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Figure 2: 3D plot of field against frequencies (centre), cross section of Re(S21) against field (upper plot),
cross section of field against Re(S21) (right plot).

• Make a new table with a column for resonance frequencies f0 and a column for the
corresponding field H.

NOTE: besides cross-sections to analyse FMR width (to obtain damping) you need to copy with you
the following files to be able analyse materials parameters from FMR data

(1) ” f ields.dat” ;
(2) ” f requency.dat” ;
(3) ”2d_array.dat”

Evaluate the second part with Origin
The second part can be evaluated in a similar way. At the end you need to create a table with at least 20
values for △H (FWHM) and their corresponding frequencies.
You can either use the matrix created for the first part with the 2D_array.dat–file and fit this time
Re(S21) against fields with a Lorentz fit. The parameter ω gives you the FWHM.
Or the other possibility is to create a new matrix with the 2D_array_derivative.dat–file and determine
the difference between the minima and maxima and multiply this value with 100/58.

Fit the final data with Origin
At this point of the analysis you should have created two tables, one with resonance frequency f0
against field H and one with the FWHM △H against frequency f .
Plot both of them. As mentioned above the first one should be fitted with the FMR expression. For
doing so, we make a little transposition of the equation

f0 =
µ0γe

2π

√
(H +HK)(H +HK +MS) (3)

=
γe

2π

√
µ0(H +HK)µ0(H +HK +MS) (4)

=
γe

2π

√
(B+BK)(B+BK +µ0MS), (5)
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exploiting the fact that in vacuum the magnetic field H⃗ and the magnetic induction B⃗ are connected by
B⃗ = µ0H⃗. For the final results we want to give BK and µ0MK in the typical SI units for the magnetic
induction, tesla (T). So far we have measured the magnetic field in units of the Gaussian unit system
(GGS), namely in Oersted (Oe). The magnetic field in CGS and SI units is related by

[H]CGS = 1Oe =
1000
4π

A
m

=
1000
4π

[H]SI. (6)

The vacuum permeability in SI units is given as

[µ0]SI = 4π ·10−7 kgm
s2A2 . (7)

Using the two equations we get for the conversion

[B]SI = [µ0H]SI = [µ0]SI ·
1000
4π

[H]CGS = 10−4 kg
s2A

= 10−4T. (8)

Thus 1Oe corresponds to 10−4T.
Having converted everything to SI units you can start with the fitting procedure with origin.

• Fitting → Nonlinear Curve Fit → choose Open Dialog... → choose Settings →
Function Selection → Category

◦ choose FMR_1 (under “—User Defined—”)

◦ if you work on another computer create your own fit with <New...>

• this should give you a fit with the Code y = a ·
√

((x+b) · (x+b+ c))

• a = γe
2π

= 1.76·1011

2π

Hz
T ≈ 2.8025 ·1010Hz/T is a fixed parameter

• play with the start values of b and c for making the fit converge

Proceed in a similar way for the second part. Fit with equation for the linewidth and again use a fixed
prefactor 4π

γe
≈ 7.1400 ·10−11 T

Hz .
For estimating the mistake use standard deviation of the fitted parameters.

A. Model E5071B

This VNA model is older than the E8363C model and thus why the maximum microwave frequency is
limited by 8.5 GHz. The proceeding is the same as in the VNA E8363, with a few exceptions:

• VNA MODEL: in the LabVIEW program (S parameters loops in field_PNA_L
50GHz_s12-solenoid6_2VNAS.vi), set the VNA model to E5071B instead of E8363C (which is
set by default).

• Stop frequency: instead of 12 GHz, it will be set to 8.5 GHz , you will have to introduce it both
in the VNA and in the LabVIEW program that controls the experiment.

• Points in trace: the maximum resolution is of 1601 points, which will be set both in the VNA
and in the LabVIEW program.

• Normalization: manual normalization is not possible to perform in the VNA, however, the
LabVIEW program for analysis (measurement_processing.vi) does it automatically, skip the
normalization step.

• Also, in this model you cannot open two windows at the same time to display the signal in
LogMag and Phase format, you have to get two traces in the same window (or visualize one at a
time, the LabVIEW program automatically sets it to measure both).

The analysis of the resonance is performed exactly the same way for both VNA models.
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